Honda Clarity Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
Not sure how many Clarity BEV drivers are still out there, but has anyone ever received a Power System Problem from charging with a specific Chargepoint Station/port? I know which Chargepoint to not use because I'll never get a full charge due to the Power System problem. The error message goes away after a few restarts of the Clarity. I hope this specific Chargepoint station isn't harming the Clarity's power system.
Speedometer Trip computer Odometer Tachometer Gauge
Speedometer Odometer Trip computer Vehicle Gauge
 

·
Super Moderator
Joined
·
526 Posts
Has your Clarity received the latest software update to correct charge issues at public charging stations ?

My '18 would not charge on public chargers until I had the software updated by Honda.
 

·
Registered
Joined
·
15 Posts
Has your Clarity received the latest software update to correct charge issues at public charging stations ?

My '18 would not charge on public chargers until I had the software updated by Honda.
How can I tell if I have the latest firmware & software updates. I don't necessarily trust my dealer because thier lying finance guy.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Has your Clarity received the latest software update to correct charge issues at public charging stations ?

My '18 would not charge on public chargers until I had the software updated by Honda.
I have a '17 BEV. I don't know if I got the update for my Clarity, but I've never had any charging issues with Chargepoint or EVgo...except for this specific charger/port and it's neighboring charger.
 

·
Registered
Joined
·
500 Posts
I have a '17 BEV. I don't know if I got the update for my Clarity, but I've never had any charging issues with Chargepoint or EVgo...except for this specific charger/port and it's neighboring charger.
I haven't seen this happen with my Clarity, but my Volt would refuse to charge on one of the older free chargers where I work. I suspect the issue is timing and the charging station and the car simply aren't talking to each other properly.
 
1 - 5 of 5 Posts
Top