Honda Clarity Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently experienced my left front headlight stop working and when I brought it into two different Honda dealers they quoted me 1400 plus labor ro replace it after 44k miles. Now my turn signals in the front and back have also stopped working. Has anyone experienced similar problems and have any suggestions
 

·
Registered
Joined
·
433 Posts
Given that your headlight and turn signals have all failed I don't think they're the problem. This sounds more like an electrical issue. Have you confirmed the fuse box doesn't have any blown fuses and that all the cables are tight?
 

·
Registered
Joined
·
5 Posts
:My driver side front headlights, running lights and turn signals failed a few months ago. Everything else worked properly. The dark units "healed themselves" a week later, then quickly failed again. My dealer also diagnosed it as a lamp failure and ordered the units. Hugely expensive. When they replaced the lamps, still no light. They explored further and found a ground fault, which when corrected made the old lamps light. A week later, same failure. This time they dug further into the grounds and found a connector that looked suspicious. After that was replaced, the lamps all lite and have been trouble free for around 3 months. The dealer tech and shop supervisors spent a lot of time with my 2018 Clarity Touring, and spent a lot of phone time with Honda techs too. I always suspect a ground on these sort of problems. Maybe your dealer tech can call Johnson Honda in Stuart Fl ((772) 320-1100) if they want to explore how my dealer finally found the issue. Good luck!
 

·
Registered
Joined
·
433 Posts
  • Like
Reactions: 4sallypat

·
Registered
Joined
·
11 Posts
Thanks for the heads-up and discussion everyone.
Perhaps there is a Honda TSB for the lighting connectivity problem?
@pob8 did you receive a list of parts involved in the fix, e.g. connectors?
 

·
Registered
Joined
·
5 Posts
No parts list (and no charge beyond the $80 diagnostic fee on the first service for this complaint. The service writer just reported what I posted, mainly that a connector that looked suspicious was replaced.
 
1 - 9 of 9 Posts
Top